$re = '/(?:\B(?!\w)|\b(?=\w))(?:\(not working text|working text)(?:(?<=\w)\b|(?<!\w)\B)/';
$str = 'working text and (not working text';
$subst = "<mark>$&</mark>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;