re = /(?:\B(?!\w)|\b(?=\w))(?:\(not working text|working text)(?:(?<=\w)\b|(?<!\w)\B)/
str = 'working text and (not working text'
subst = '<mark>$&</mark>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result