import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\B(?!\\w)|\\b(?=\\w))(?:\\(not working text|working text)(?:(?<=\\w)\\b|(?<!\\w)\\B)";
final String string = "working text and (not working text";
final String subst = "<mark>$&</mark>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}