const regex = /(?:\B(?!\w)|\b(?=\w))(?:\(not working text|working text)(?:(?<=\w)\b|(?<!\w)\B)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\B(?!\\w)|\\b(?=\\w))(?:\\(not working text|working text)(?:(?<=\\w)\\b|(?<!\\w)\\B)', 'g')
const str = `working text and (not working text`;
const subst = `<mark>$&</mark>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);