use strict;
my $str = 'working text and (not working text';
my $regex = qr/(?:\B(?!\w)|\b(?=\w))(?:\(not working text|working text)(?:(?<=\w)\b|(?<!\w)\B)/p;
my $subst = '<mark>$&</mark>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";