# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s(\d{4})\s/(\g<0>)/gm;t' <<< "My movie 2003 dvdrip.mkv
"