re = /\s(\d{4})\s/m
str = 'My movie 2003 dvdrip.mkv
'
subst = '(\\g<0>)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result