$re = '/\s(\d{4})\s/m';
$str = 'My movie 2003 dvdrip.mkv
';
$subst = "(\g<0>)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;