const regex = new RegExp('\\s(\\d{4})\\s', 'gm')
const str = `My movie 2003 dvdrip.mkv
`;
const subst = `(\g<0>)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);