import Foundation
let pattern = #"\s(\d{4})\s"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
My movie 2003 dvdrip.mkv
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"(\g<0>)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)