use strict;
my $str = 'My movie 2003 dvdrip.mkv
';
my $regex = qr/\s(\d{4})\s/mp;
my $subst = '(\\g<0>)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";