#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!\\)(?!.*\\)_(?=.*Lnk)"
Local $sString = "Application=M:\8TB+\GOG.Com\99_Levels_To_Hell\Launch_99_Levels_To_Hell.Lnk" & @CRLF & _
"WorkingFolder=M:\8TB+\GOG.Com\99_Levels_To_Hell\" & @CRLF & _
"" & @CRLF & _
"ExitMethod=WinClose"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")