using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\\)(?!.*\\)_(?=.*Lnk)";
string input = @"Application=M:\8TB+\GOG.Com\99_Levels_To_Hell\Launch_99_Levels_To_Hell.Lnk
WorkingFolder=M:\8TB+\GOG.Com\99_Levels_To_Hell\
ExitMethod=WinClose";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}