$re = '/(?<!\\\\)(?!.*\\\\)_(?=.*Lnk)/';
$str = 'Application=M:\\8TB+\\GOG.Com\\99_Levels_To_Hell\\Launch_99_Levels_To_Hell.Lnk
WorkingFolder=M:\\8TB+\\GOG.Com\\99_Levels_To_Hell\\
ExitMethod=WinClose';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);