re = /(?<!\\)(?!.*\\)_(?=.*Lnk)/
str = 'Application=M:\\8TB+\\GOG.Com\\99_Levels_To_Hell\\Launch_99_Levels_To_Hell.Lnk
WorkingFolder=M:\\8TB+\\GOG.Com\\99_Levels_To_Hell\\
ExitMethod=WinClose'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end