const regex = /(?<!\\)(?!.*\\)_(?=.*Lnk)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\\\)(?!.*\\\\)_(?=.*Lnk)', 'g')
const str = `Application=M:\\8TB+\\GOG.Com\\99_Levels_To_Hell\\Launch_99_Levels_To_Hell.Lnk
WorkingFolder=M:\\8TB+\\GOG.Com\\99_Levels_To_Hell\\
ExitMethod=WinClose`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}