import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\\\)(?!.*\\\\)_(?=.*Lnk)";
final String string = "Application=M:\\8TB+\\GOG.Com\\99_Levels_To_Hell\\Launch_99_Levels_To_Hell.Lnk\n"
+ "WorkingFolder=M:\\8TB+\\GOG.Com\\99_Levels_To_Hell\\\n\n"
+ "ExitMethod=WinClose";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}