#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([0-9]{4})(-)([A-Z]+)?(\s)?([A-Z]+)?(-)?(\s)?([A-Z]+)?(\s)?([A-Z]+)?"
Local $sString = "3000-INSURANCE PAYMENT (INSURANCE)" & @CRLF & _
"3000-INSURANCE (INSURANCE)" & @CRLF & _
"1001-PATIENT CO-PAYMENT" & @CRLF & _
"2000-INSURANCE PAYMENT" & @CRLF & _
"3000-CONTRACTUAL WRITE OFF" & @CRLF & _
"9817-PAST TIMELY TO SUBMIT" & @CRLF & _
"9880-MEDICARE SEQUESTRATION" & @CRLF & _
"3115-TIMELY FILING" & @CRLF & _
"9532-LIABILITY SETTLEMENT ADJUSTMENT" & @CRLF & _
"9880-MEDICARE SEQUESTRATION" & @CRLF & _
"3115-TIMELY FILING" & @CRLF & _
"9532-LIABILITY SETTLEMENT ADJUSTMENT" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")