package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9]{4})(-)([A-Z]+)?(\s)?([A-Z]+)?(-)?(\s)?([A-Z]+)?(\s)?([A-Z]+)?`)
var str = `3000-INSURANCE PAYMENT (INSURANCE)
3000-INSURANCE (INSURANCE)
1001-PATIENT CO-PAYMENT
2000-INSURANCE PAYMENT
3000-CONTRACTUAL WRITE OFF
9817-PAST TIMELY TO SUBMIT
9880-MEDICARE SEQUESTRATION
3115-TIMELY FILING
9532-LIABILITY SETTLEMENT ADJUSTMENT
9880-MEDICARE SEQUESTRATION
3115-TIMELY FILING
9532-LIABILITY SETTLEMENT ADJUSTMENT
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}