// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([0-9]{4})(-)([A-Z]+)?(\s)?([A-Z]+)?(-)?(\s)?([A-Z]+)?(\s)?([A-Z]+)?").unwrap();
let string = "3000-INSURANCE PAYMENT (INSURANCE)
3000-INSURANCE (INSURANCE)
1001-PATIENT CO-PAYMENT
2000-INSURANCE PAYMENT
3000-CONTRACTUAL WRITE OFF
9817-PAST TIMELY TO SUBMIT
9880-MEDICARE SEQUESTRATION
3115-TIMELY FILING
9532-LIABILITY SETTLEMENT ADJUSTMENT
9880-MEDICARE SEQUESTRATION
3115-TIMELY FILING
9532-LIABILITY SETTLEMENT ADJUSTMENT
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}