import Foundation
let pattern = #"([0-9]{4})(-)([A-Z]+)?(\s)?([A-Z]+)?(-)?(\s)?([A-Z]+)?(\s)?([A-Z]+)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
3000-INSURANCE PAYMENT (INSURANCE)
3000-INSURANCE (INSURANCE)
1001-PATIENT CO-PAYMENT
2000-INSURANCE PAYMENT
3000-CONTRACTUAL WRITE OFF
9817-PAST TIMELY TO SUBMIT
9880-MEDICARE SEQUESTRATION
3115-TIMELY FILING
9532-LIABILITY SETTLEMENT ADJUSTMENT
9880-MEDICARE SEQUESTRATION
3115-TIMELY FILING
9532-LIABILITY SETTLEMENT ADJUSTMENT
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)