use strict;
my $str = '3000-INSURANCE PAYMENT (INSURANCE)
3000-INSURANCE (INSURANCE)
1001-PATIENT CO-PAYMENT
2000-INSURANCE PAYMENT
3000-CONTRACTUAL WRITE OFF
9817-PAST TIMELY TO SUBMIT
9880-MEDICARE SEQUESTRATION
3115-TIMELY FILING
9532-LIABILITY SETTLEMENT ADJUSTMENT
9880-MEDICARE SEQUESTRATION
3115-TIMELY FILING
9532-LIABILITY SETTLEMENT ADJUSTMENT
';
my $regex = qr/([0-9]{4})(-)([A-Z]+)?(\s)?([A-Z]+)?(-)?(\s)?([A-Z]+)?(\s)?([A-Z]+)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}