using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9]{4})(-)([A-Z]+)?(\s)?([A-Z]+)?(-)?(\s)?([A-Z]+)?(\s)?([A-Z]+)?";
string input = @"3000-INSURANCE PAYMENT (INSURANCE)
3000-INSURANCE (INSURANCE)
1001-PATIENT CO-PAYMENT
2000-INSURANCE PAYMENT
3000-CONTRACTUAL WRITE OFF
9817-PAST TIMELY TO SUBMIT
9880-MEDICARE SEQUESTRATION
3115-TIMELY FILING
9532-LIABILITY SETTLEMENT ADJUSTMENT
9880-MEDICARE SEQUESTRATION
3115-TIMELY FILING
9532-LIABILITY SETTLEMENT ADJUSTMENT
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}