using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.{5,})\s*\1";
string substitution = @"\1";
string input = @"Vsuvka redukovaná Vsuvka redukovaná
Quick mini ventil 16x3/4"" Quick mini ventil 16x3/4""
Mechanická T-spojka 25 x 25 x 25 Mechanická T-spojka 25 x 25 x 25
Mechanické Popup koleno 90° 32 x 32 x 3/4"" s vnútorným závitom Mechanické Popup koleno 90° 32 x 32 x 3/4"" s vnútorným závitom";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}