import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.{5,})\\s*\\1";
final String string = "Vsuvka redukovaná Vsuvka redukovaná\n"
+ "Quick mini ventil 16x3/4\" Quick mini ventil 16x3/4\"\n"
+ "Mechanická T-spojka 25 x 25 x 25 Mechanická T-spojka 25 x 25 x 25\n"
+ "Mechanické Popup koleno 90° 32 x 32 x 3/4\" s vnútorným závitom Mechanické Popup koleno 90° 32 x 32 x 3/4\" s vnútorným závitom";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}