import re
regex = re.compile(r"(.{5,})\s*\1", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Vsuvka redukovaná Vsuvka redukovaná\n"
"Quick mini ventil 16x3/4\" Quick mini ventil 16x3/4\"\n"
"Mechanická T-spojka 25 x 25 x 25 Mechanická T-spojka 25 x 25 x 25\n"
"Mechanické Popup koleno 90° 32 x 32 x 3/4\" s vnútorným závitom Mechanické Popup koleno 90° 32 x 32 x 3/4\" s vnútorným závitom")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)