$re = '/(.{5,})\s*\1/mi';
$str = 'Vsuvka redukovaná Vsuvka redukovaná
Quick mini ventil 16x3/4" Quick mini ventil 16x3/4"
Mechanická T-spojka 25 x 25 x 25 Mechanická T-spojka 25 x 25 x 25
Mechanické Popup koleno 90° 32 x 32 x 3/4" s vnútorným závitom Mechanické Popup koleno 90° 32 x 32 x 3/4" s vnútorným závitom';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;