const regex = new RegExp('(.{5,})\\s*\\1', 'gmi')
const str = `Vsuvka redukovaná Vsuvka redukovaná
Quick mini ventil 16x3/4" Quick mini ventil 16x3/4"
Mechanická T-spojka 25 x 25 x 25 Mechanická T-spojka 25 x 25 x 25
Mechanické Popup koleno 90° 32 x 32 x 3/4" s vnútorným závitom Mechanické Popup koleno 90° 32 x 32 x 3/4" s vnútorným závitom`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);