# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*?([^_]+:).+?([^_]+_[^_]+)@.*/\1\2/gm;t' <<< "mynumber
Raja_trial1:gill234_pit_type_id@rng
Raja_trial1:Perm_king_que@pmcx[x1]
Dun_mere_fer45:Hisota_gul_har23@cyu[9]
Pit_chb1:reet_kaam_nix@opdx[x1]
"