$re = '/.*?([^_]+:).+?([^_]+_[^_]+)@.*/m';
$str = 'mynumber
Raja_trial1:gill234_pit_type_id@rng
Raja_trial1:Perm_king_que@pmcx[x1]
Dun_mere_fer45:Hisota_gul_har23@cyu[9]
Pit_chb1:reet_kaam_nix@opdx[x1]
';
$subst = "\1\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;