const regex = new RegExp('.*?([^_]+:).+?([^_]+_[^_]+)@.*', 'gm')
const str = `mynumber
Raja_trial1:gill234_pit_type_id@rng
Raja_trial1:Perm_king_que@pmcx[x1]
Dun_mere_fer45:Hisota_gul_har23@cyu[9]
Pit_chb1:reet_kaam_nix@opdx[x1]
`;
const subst = `\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);