import Foundation
let pattern = #".*?([^_]+:).+?([^_]+_[^_]+)@.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
mynumber
Raja_trial1:gill234_pit_type_id@rng
Raja_trial1:Perm_king_que@pmcx[x1]
Dun_mere_fer45:Hisota_gul_har23@cyu[9]
Pit_chb1:reet_kaam_nix@opdx[x1]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)