#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*?([^_]+:).+?([^_]+_[^_]+)@.*"
Local $sString = "mynumber" & @CRLF & _
"Raja_trial1:gill234_pit_type_id@rng" & @CRLF & _
"Raja_trial1:Perm_king_que@pmcx[x1]" & @CRLF & _
"Dun_mere_fer45:Hisota_gul_har23@cyu[9]" & @CRLF & _
"Pit_chb1:reet_kaam_nix@opdx[x1]" & @CRLF & _
""
Local $sSubst = "\1\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)