# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*?([^_]+:).+?([^_]+_[^_]+)@.*"
test_str = ("mynumber\n"
"Raja_trial1:gill234_pit_type_id@rng\n"
"Raja_trial1:Perm_king_que@pmcx[x1]\n"
"Dun_mere_fer45:Hisota_gul_har23@cyu[9]\n"
"Pit_chb1:reet_kaam_nix@opdx[x1]\n")
subst = "\\1\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.