import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\#+ \\K\n"
+ "(?: (?<five> \\d+) , )??\n"
+ "(?: (?<four> \\d+) , )??\n"
+ "(?: (?<three> \\d+) , )??\n"
+ "(?: (?<two> \\d+) , )?\n"
+ "(?<one>\\d+)\n"
+ "(?!\\S)";
final String string = "~~~~~~~~#5,4,3,2,1\n"
+ "~~~~~~~##4,3,2,1\n"
+ "~~~~~~###3,2,1\n"
+ "~~~~~####2,1\n"
+ "~~~~#####1 >))))))°>\n"
+ "~~~~~####2,1\n"
+ "~~~~~~###3,2,1\n"
+ "~~~~~~~##4,3,2,1\n"
+ "~~~~~~~~#5,4,3,2,1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}