const regex = /\#+ \K
(?: (?<five> \d+) , )??
(?: (?<four> \d+) , )??
(?: (?<three> \d+) , )??
(?: (?<two> \d+) , )?
(?<one>\d+)
(?!\S)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\#+ \\K
(?: (?<five> \\d+) , )??
(?: (?<four> \\d+) , )??
(?: (?<three> \\d+) , )??
(?: (?<two> \\d+) , )?
(?<one>\\d+)
(?!\\S)', 'gm')
const str = `~~~~~~~~#5,4,3,2,1
~~~~~~~##4,3,2,1
~~~~~~###3,2,1
~~~~~####2,1
~~~~#####1 >))))))°>
~~~~~####2,1
~~~~~~###3,2,1
~~~~~~~##4,3,2,1
~~~~~~~~#5,4,3,2,1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}