import Foundation
let pattern = ##"""
\#+ \K
(?: (?<five> \d+) , )??
(?: (?<four> \d+) , )??
(?: (?<three> \d+) , )??
(?: (?<two> \d+) , )?
(?<one>\d+)
(?!\S)
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = ######"""
~~~~~~~~#5,4,3,2,1
~~~~~~~##4,3,2,1
~~~~~~###3,2,1
~~~~~####2,1
~~~~#####1 >))))))°>
~~~~~####2,1
~~~~~~###3,2,1
~~~~~~~##4,3,2,1
~~~~~~~~#5,4,3,2,1
"""######
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)