$re = '/\#+ \K
(?: (?<five> \d+) , )??
(?: (?<four> \d+) , )??
(?: (?<three> \d+) , )??
(?: (?<two> \d+) , )?
(?<one>\d+)
(?!\S)/mx';
$str = '~~~~~~~~#5,4,3,2,1
~~~~~~~##4,3,2,1
~~~~~~###3,2,1
~~~~~####2,1
~~~~#####1 >))))))°>
~~~~~####2,1
~~~~~~###3,2,1
~~~~~~~##4,3,2,1
~~~~~~~~#5,4,3,2,1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);