re = /\#+ \K
(?: (?<five> \d+) , )??
(?: (?<four> \d+) , )??
(?: (?<three> \d+) , )??
(?: (?<two> \d+) , )?
(?<one>\d+)
(?!\S)/mx
str = '~~~~~~~~#5,4,3,2,1
~~~~~~~##4,3,2,1
~~~~~~###3,2,1
~~~~~####2,1
~~~~#####1 >))))))°>
~~~~~####2,1
~~~~~~###3,2,1
~~~~~~~##4,3,2,1
~~~~~~~~#5,4,3,2,1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end