using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\<IpAddress\>(?<IP>\d+\.\d+\.\d+\.\d+)";
string input = @" <IpAddress>8.8.8.8, 2.2.2.2</IpAddress>
<blahblah>1.1.1.1, 2.2.2.2, x.x.x.x</blahblah>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}