const regex = /\<IpAddress\>(?<IP>\d+\.\d+\.\d+\.\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\<IpAddress\\>(?<IP>\\d+\\.\\d+\\.\\d+\\.\\d+)', 'gm')
const str = ` <IpAddress>8.8.8.8, 2.2.2.2</IpAddress>
<blahblah>1.1.1.1, 2.2.2.2, x.x.x.x</blahblah>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}