package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\<IpAddress\>(?<IP>\d+\.\d+\.\d+\.\d+)`)
var str = ` <IpAddress>8.8.8.8, 2.2.2.2</IpAddress>
<blahblah>1.1.1.1, 2.2.2.2, x.x.x.x</blahblah>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}