re = /\<IpAddress\>(?<IP>\d+\.\d+\.\d+\.\d+)/m
str = ' <IpAddress>8.8.8.8, 2.2.2.2</IpAddress>
<blahblah>1.1.1.1, 2.2.2.2, x.x.x.x</blahblah>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end