import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\<IpAddress\\>(?<IP>\\d+\\.\\d+\\.\\d+\\.\\d+)";
final String string = " <IpAddress>8.8.8.8, 2.2.2.2</IpAddress>\n"
+ " <blahblah>1.1.1.1, 2.2.2.2, x.x.x.x</blahblah>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}