# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\.)(.+)(\[bbcode\])/$1/gUs;t' <<< "Example 1:
Blah blah blah. THIS SENTENCE SHOULD BE SELECTED [bbcode]
Example 2:
Blah blah blah
THIS SENTENCE SHOULD BE SELECTED [bbcode]
Example 3:
Test. Blah blah blah. Test.
A trick sentence. THIS SENTENCE SHOULD BE SELECTED
[bbcode]"