$re = '/(?:\.)(.+)(\[bbcode\])/Us';
$str = 'Example 1:
Blah blah blah. THIS SENTENCE SHOULD BE SELECTED [bbcode]
Example 2:
Blah blah blah
THIS SENTENCE SHOULD BE SELECTED [bbcode]
Example 3:
Test. Blah blah blah. Test.
A trick sentence. THIS SENTENCE SHOULD BE SELECTED
[bbcode]';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;