import re
regex = re.compile(r"(?:\.)(.+)(\[bbcode\])", flags=re.DOTALL)
test_str = ("Example 1:\n"
"Blah blah blah. THIS SENTENCE SHOULD BE SELECTED [bbcode]\n\n"
"Example 2:\n"
"Blah blah blah\n"
"THIS SENTENCE SHOULD BE SELECTED [bbcode]\n\n"
"Example 3:\n"
"Test. Blah blah blah. Test.\n\n"
"A trick sentence. THIS SENTENCE SHOULD BE SELECTED\n\n\n"
"[bbcode]")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)