import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\.)(.+)(\\[bbcode\\])";
final String string = "Example 1:\n"
+ "Blah blah blah. THIS SENTENCE SHOULD BE SELECTED [bbcode]\n\n"
+ "Example 2:\n"
+ "Blah blah blah\n"
+ "THIS SENTENCE SHOULD BE SELECTED [bbcode]\n\n"
+ "Example 3:\n"
+ "Test. Blah blah blah. Test.\n\n"
+ "A trick sentence. THIS SENTENCE SHOULD BE SELECTED\n\n\n"
+ "[bbcode]";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CHARACTER_CLASS | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}