use strict;
my $str = 'Example 1:
Blah blah blah. THIS SENTENCE SHOULD BE SELECTED [bbcode]
Example 2:
Blah blah blah
THIS SENTENCE SHOULD BE SELECTED [bbcode]
Example 3:
Test. Blah blah blah. Test.
A trick sentence. THIS SENTENCE SHOULD BE SELECTED
[bbcode]';
my $regex = qr/(?:\.)(.+)(\[bbcode\])/sp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";