using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\.)(.+)(\[bbcode\])";
string substitution = @"$1";
string input = @"Example 1:
Blah blah blah. THIS SENTENCE SHOULD BE SELECTED [bbcode]
Example 2:
Blah blah blah
THIS SENTENCE SHOULD BE SELECTED [bbcode]
Example 3:
Test. Blah blah blah. Test.
A trick sentence. THIS SENTENCE SHOULD BE SELECTED
[bbcode]";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}